From 8a3692d73403e8fea9d127e4bc043060c7e511b5 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Tue, 26 Sep 2023 12:07:01 +0200
Subject: Move to the new arm cross compilation

---
 gb.scm | 69 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 68 insertions(+), 1 deletion(-)

diff --git a/gb.scm b/gb.scm
index 2d4ac2b..6dfd0fc 100644
--- a/gb.scm
+++ b/gb.scm
@@ -160,7 +160,7 @@
                       (copy-recursively "output/libseven" (assoc-ref outputs "out")))))
         #:tests? #f))
     (build-system gnu-build-system)
-    (inputs (list arm-none-eabi-nano-toolchain-7-2018-q2-update))
+    (inputs (list (make-arm-none-eabi-nano-toolchain-7-2018-q2-update)))
     (synopsis "A fully from-scratch library for GBA development, meant to
 replace existing libraries like libgba or libtonc.")
     (description "Goals:
@@ -170,3 +170,70 @@ replace existing libraries like libgba or libtonc.")
   - High-quality, understandable documentation")
     (home-page  "https://github.com/LunarLambda/libseven")
     (license license:mpl2.0)))
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
+;; TODO: Make the toolchain like `propeller-toolchain`!
+;; Find interesting tools and add all them here. good resource: http://www.devrs.com/gba/software.php
+;; - Interesting libs:
+;;   - https://github.com/jesusatc/libgba (don't mix with the next)
+;;   - https://github.com/devkitPro/libgba
+;;   - https://github.com/devkitPro/libtonc
+;;      - Difference between libgba and libtonc: https://github.com/exelotl/libtonc-template
+;; These may be too complex
+;;
+;;
+;; (define-public libtonc
+;;   ;https://github.com/devkitPro/pacman-packages/blob/master/libtonc/PKGBUILD
+;;   (package
+;;     (name "libtonc")
+;;     (version "1.4.3")
+;;     (source (origin
+;;               (method url-fetch)
+;;               (uri "")
+;;               (sha256
+;;                 (base32
+;;                   "1rlhyc9dsdxcmaih3x9qjb3ihr2xxz1rw42ijbz2ylymn9p133gh"))))
+;;     (build-system gnu-build-system)
+;;     (inputs (list gba-toolchain-mini))
+;;     (synopsis "A nintendo GameBoy Advance library.")
+;;     (description "")
+;;     (home-page "http://www.coranac.com/projects/#tonc")
+;;     (license license:expat)
+;;     ))
+;;
+;; (define-public gba-toolchain-full
+;;   (package
+;;     (name "gba-toolchain-full")
+;;     (synopsys "GameBoy Advance toolchain with many intersting tools")
+;;     ))
+;;
+;; (define-package devkitpro
+;;   ; https://github.com/devkitPro/buildscripts
+;; )
+;;
+;; (define-public libgba
+;;   ; https://github.com/devkitPro/pacman-packages/blob/master/libgba/PKGBUILD
+;;   (package
+;;     (name "libgba")
+;;     (version "0.5.2")
+;;     ))
+;;
+;; (define-public crt-files
+;;   ; https://github.com/devkitPro/pacman-packages/blob/master/devkitarm/devkitarm-crtls/PKGBUILD
+;;   ; https://github.com/devkitpro/devkitarm-crtls
+;;   (package
+;;     (name "crt-files")
+;;     ))
-- 
cgit v1.2.3