summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaitz Zárraga <ekaitz.zarraga@protonmail.com>2019-07-22 13:03:19 +0200
committerEkaitz Zárraga <ekaitz.zarraga@protonmail.com>2019-07-22 13:03:19 +0200
commit27a6e541082ff83d6fadb61caf0bb52d2202ab32 (patch)
treece2ca40c1e7d32c9048acca8ce4db31a87d15ad5
parent70bdd1526ba1b308a88d50fb5c28c03022663103 (diff)
Add patches and some more
-rw-r--r--patches/sc-im.patch34
-rw-r--r--sc-im.scm34
2 files changed, 61 insertions, 7 deletions
diff --git a/patches/sc-im.patch b/patches/sc-im.patch
new file mode 100644
index 0000000..e89e7b4
--- /dev/null
+++ b/patches/sc-im.patch
@@ -0,0 +1,34 @@
+diff --git a/src/Makefile b/src/Makefile
+index fb08e9a..cb6ea65 100755
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -38,7 +38,7 @@ CFLAGS += -DINS_HISTORY_FILE=\".$(name)info\"
+ # Comment out to disable undo/redo support
+ CFLAGS += -DUNDO
+ # Maximum number of rows in spreadsheet. Up to 1048576
+-CFLAGS += -DMAXROWS=65536
++CFLAGS += -DMAXROWS=1048576
+ # Used for date formatting with C-d shortcut using you local d_fmt
+ CFLAGS += -DUSELOCALE
+
+@@ -47,16 +47,16 @@ CFLAGS += -DUSELOCALE
+ # Choose one of the following commands for copying to different clipboards:
+ # You can later change it at runtime.
+ #to copy to tmux clipboard:
+-CFLAGS += -DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""tmux load-buffer"\"
++#CFLAGS += -DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""tmux load-buffer"\"
+ #to copy to X clipboard:
+-#CFLAGS += -DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""xclip -i -selection clipboard <"\"
++CFLAGS += -DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""xclip -i -selection clipboard <"\"
+ #to copy to OSX clipboard:
+ #CFLAGS += -DDEFAULT_COPY_TO_CLIPBOARD_CMD=\""pbcopy <"\"
+ #
+ # Choose one of the proposed commands for pasting from different clipboards:
+ # You can later change it at runtime.
+-CFLAGS += -DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""tmux show-buffer"\"
+-#CFLAGS += -DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""xclip -o -selection clipboard"\"
++#CFLAGS += -DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""tmux show-buffer"\"
++CFLAGS += -DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""xclip -o -selection clipboard"\"
+ #CFLAGS += -DDEFAULT_PASTE_FROM_CLIPBOARD_CMD=\""pbpaste"\"
+
+ # Uncomment for basic XLS import. Requires libxlsreader
diff --git a/sc-im.scm b/sc-im.scm
index 0fbcb36..2b6e5bb 100644
--- a/sc-im.scm
+++ b/sc-im.scm
@@ -4,10 +4,15 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix licenses)
- #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages bison)
- #:use-module (gnu packages lua)
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages lua) ; I think it's not taking it well
+
+ ; It's not really a dependency, can be changed at runtime
+ ; #:use-module (gnu packages xclip)
+ ; If we add it, it must be part of `propagated-inputs`
)
(define-public sc-im
@@ -22,13 +27,14 @@
(commit commit-ref)))
(sha256
(base32
- "11cdz2jm9bsp693xj708m38dpcxysb0mbdsw8fwvsmcr44sjcx6v"))))
+ "11cdz2jm9bsp693xj708m38dpcxysb0mbdsw8fwvsmcr44sjcx6v"))
+ (patches (search-patches
+ "sc-im.patch"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f
#:make-flags (list
- "-C"
- "src"
+ "-C" "src"
"CC=gcc"
(string-append "prefix=" (assoc-ref %outputs "out")))
#:phases (modify-phases
@@ -38,7 +44,21 @@
(native-inputs `(("pkg-config" ,pkg-config)
("bison" ,bison)
("lua" ,lua)))
- (synopsis "")
- (description "")
+ (synopsis "Spreadsheet program based on SC")
+
+ (description "
+Capabilities: UNDO / REDO. 65.536 rows and 702 columns supported (the number of
+rows can be expanded to 1.048.576 if wished). CSV / TAB delimited / XLSX file
+import and export. Scripting support with LUA. Also with triggers and c dynamic
+linked modules. Clipboard support. GNUPlot interaction. Key-mappings. Sort of
+rows. Filter of rows. Subtotals. Cell shifting. 256 color support - screen
+colors can be customized by user, even at runtime. Colorize cells or give them
+format such as bold or underline. Wide character support. The following
+alphabets are supported: English, Spanish, French, Italian, German, Portuguese,
+Russian, Ukrainian, Greek, Turkish, Czech, Japanese, Chinese. Autobackup.
+Implement external functions in the language you prefer and use them in SC-IM.
+Use SC-IM as a non-interactive calculator, reading its input from a external
+script. More movements commands implemented! Input and Output was completely
+rewritten.")
(home-page "https://github.com/andmarti1424/sc-im")
(license bsd-3)))) ; I'm not sure